Función SUMAR.SI en Excel o como hacer una suma condicional

La función SUMAR.SI en Excel nos permite sumar rangos que cumplen cierto criterio.

Existen dos maneras de usar esta función:

1. Si el propio rango a sumar es el que tiene que cumplir la condición.

Por ejemplo, si en la columna A tenemos valores negativos y positivos y queremos saber cuanto suman los positivos.

2. Si el rango que queremos sumar está condicionando por otro rango.

Por ejemplo, si en la columna A tenemos números de cuenta y en la B tenemos las entradas y las salidas y queremos sumar las entradas y salidas de una cuenta en concreto.

SINTAXIS

La sintaxis de la función SUMAR.SI en Excel es muy sencilla:

=SUMAR.SI(rango; criterio;[rango_suma])
  • Rango: es donde se encuentra nuestro rango de suma en el primer caso (columna A) o el rango donde está nuestra condición en el segundo caso (columna A).
  • Criterio: el criterio que queremos aplicar
  • [rango_suma]: en el segundo caso, será el rango donde están los valores que queremos sumar (columna B) una vez cumplida la condición impuesta por el criterio. Recuerda que se pone en corchetes [ ] los valores no obligatorios.

El tema de los rangos es relativamente sencillo. El asunto se complica en la sintaxis del criterio.

Ejemplos de criterios

Mayor que 0 = “>0”

=CONTAR.SI(A1:A10;">0")

Igual a 32 = 32

=CONTAR.SI(A1:A10;32)

Igual que la cuenta ABC003 = “ABC003”

=CONTAR.SI(A1:A10;"ABC003")

Igual que la celda C1 = C1

=CONTAR.SI(A1:A10;C1)

Mayor que la celda C1 = “>”&C1

=CONTAR.SI(A1:A10;">"&C1)

Ejercicio propuesto para aprender a usar SUMAR.SI en Excel

Supongamos que tenemos la siguiente lista de valores en la columna A y B (puedes copiarlos y pegarlos en una hoja de Excel):

A10
A2
AA5
BB9
AA5
A9
A2
A6
AA5
BB10

Queremos saber los siguientes valores:

  • Suma de los valores A
  • Suma de los valores AA
  • Suma de los valores >5
  • Suma de los valores <10

Para resolverlo hemos usado las siguientes fórmulas:

  • =SUMAR.SI(A1:A10;"A";B1:B10)
  • =SUMAR.SI(A1:A10;"AA";B1:B10)
  • =SUMAR.SI(B1:B10;">5")
  • =SUMAR.SI(B1:B10;"<10")

Bonus track: más ejemplos de suma condicional en Excel

Si quieres aprender más sobre cómo usar la función SUMAR.SI en Excel puede que te interese echarle un visazo a este artículo sobre tres maneras diferentes para hacer sumas condicionales en el que además aprenderás a usar la función SUMAR.SI.CONJUNTO.

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza... no dudes en contactar con él para cualquier duda que tengas.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información ACEPTAR

Aviso de cookies
Shares
Share This