Función SI en Excel

La función SI en Excel es una de las funciones más utilizadas. Nos permite evaluar una condición y en función del resultado nos dará un resultado u otro. Esta función es de las que se consideran básicas en Excel y nos permite combinarla con otras muchas funciones incluso siendo un argumento de las mismas.

Sintaxis

La sintaxis de la función SI en Excel es muy sencilla pero hay que comprender unos conceptos clave como veremos un poco más adelante. La sintaxis es:

SI(prueba_lógica;valor_si_verdadero;valor_si_falso)

Quizás con la siguiente imagen se pueda entender un poco mejor:

función si en Excel

La función SI tiene un claro carácter lógico. Evalúa si se cumple o no una determinada condición (prueba_lógica) y en función de ello devuelve un resultado (valor_si_verdadero) u otro (valor_si_falso). Como vemos en la imagen anterior, de la prueba lógica sólo pueden salir dos resultados: el verdadero o el falso.

A continuación vamos a explicar cada uno de sus argumentos

  • Prueba_lógica: Cualquier condición que pueda evaluarse como VERDADERA o FALSA. Para ello, Excel pone a nuestra disposición los seis operadores lógicos (>, <, =, >=, <=, <>).
  • Valor_si_verdadero: La función devolverá lo que aquí le indiquemos en caso de que la prueba lógica haya resultado ser verdadera. Este resultado podrá ser desde un texto, en cuyo caso deberá ir entre comillas (por ejemplo “soy un texto” o un texto vacío “”) hasta un número (-2, 0, 1478 etc). En caso de no escribir absolutamente nada en este argumento, la función por defecto devolverá 0 (cero).
  • Valor_si_falso: La función devolverá lo que aquí le indiquemos en caso de que la prueba lógica haya resultado ser falsa. De manera análoga a cuando era verdadero, debemos asignar un valor. En caso de no poner este argumento opcional Excel devolverá en este caso el operador lógico FALSO.

Ejemplos de la función SI en Excel

Ejemplo 1: función SI con resultado VERDADERO

En este ejemplo queremos saber si la celda A6 es mayor que la celda A7. Para ello escribimos la función que podemos ver a continuación.

=SI(A6>A7;VERDADERO;FALSO)

Ten en cuenta que en la función SI o en cualquier función en Excel no hace falta que escribas VERDADERO o FALSO entre comillas puesto que son variables preparadas por Excel.

En cambio, si quieres poner otros valores de texto sí que deberás escribir las soluciones entre comillas:

=SI(A6>A7;"Es mayor";"No es mayor")

El resultado de la función SI en Excel en este caso es VERDADERO.

Ejemplo 2: función SI con suma en valor si verdadero

En el mismo ejemplo que el anterior pero cambiando las celdas queremos que la función devuelva la suma de los números en caso de ser VERDADERO.

Para ello aplicaremos la función SI de Excel con este formato:

=SI(A13 > A14; A13 + A14 ; FALSO)

Como en este caso el valor de A13  es mayor que el de A15, entonces la función nos devolverá el número 25. Ahora bien, si la prueba lógica no se hubiese cumplido el valor que hubiera arrojado es el valor FALSO.

Ejercicio

En la siguiente hoja Excel vamos a calcular la comisión que va a cobrar un empleado en función de lo que haya facturado, de manera que si se trata de una cantidad superior a 10.000 €, el empleado percibirá una comisión del 5% el total de la facturación, mientras que si es inferior a 10.000€, no percibirá nada.

En la imagen puede verse el problema planteado y formulado en Excel.

función si en excel

Con la instrucción que aparece en la imagen obtendremos los resultados deseados. En concreto le estamos diciendo al programa:

  • En la celda B3 ponemos la facturación
  • En la celda B4 calculamos la comisión.
  • Si la facturación B3 > 10.000 (por ejemplo B3 = 15.000), el valor que aparecerá en la comisión B4 será el 5% de esa cantidad, en este caso (5*15.000)/100 = 750 euros.
  • Si por el contrario B3 < 10.000 (por ejemplo B3 = 8.000), en B4 podremos leer: No se ha alcanzado el mínimo de facturación.

 

AMPLIACIÓN: función SI en Excel con varias condiciones

En ocasiones tenemos que hacer cumplir dos condiciones de Excel en una misma función SI o en varias funciones SI. A continuación vamos a explicarte cómo se puede hacer una función SI en Excel con dos condiciones.

Caso 1: Cuando anidamos dos funciones SI una dentro de la otra.

Este es el caso por el que empezamos casi todos en Excel, se trata de poner una serie de condiciones anidadas. Por ejemplo, si Yolanda es rubia y además si Yolanda es guapa entonces pondremos “OK” pero si no lo es entonces pondremos “NO OK”.

Vamos a verlo con un dibujo para que se entienda mejor como el siguiente.

funcion si en excel

Como ves es un árbol de decisión y al final hemos visto que  tiene 2 ramas.

Para construir esto en Excel primero escribiremos la primera condición SI tal y comos sigue: Si Yolanda es Rubia entonces en el valor si verdadero escribiremos OK y luego en valor FALSO escribiremos NO OK.

Ten en cuenta que la prueba lógica deberán ser celdas o referencias en Excel por lo que vamos a asumir que en la celda A1 de una hoja de Excel pone si Yolanda es Rubia o Morena…..

=SI( A1 = "Rubia" ; "OK" ; "NO OK")

Como puedes ver en la función anterior sólo tenemos una condición… ahora vamos a añadir la segunda condición, es decir, si YOLANDA es guapa. Supongamos que este atributo de YOLANDA se encuentra en la celda A2. Para ello añadiremos una segunda función SI dentro de la primera función SI en Excel.

=SI( A1 = "Rubia" ; SI( A2 = "Guapa"; "OK"; "NO OK") ; "NO OK")

lo que equivale a:

=SI( A1 = "Rubia" ; SI( A2 = "Guapa"; "Es rubia y guapa"; "Es rubia pero no guapa") ; "ni rubia ni guapa")

Como puedes ver, esta función es algo más complicada pero con un poco de práctica podrás hacer miles de maravillas y complicar las funciones tanto como quieras.

Caso 2: Cuando tenemos dos condiciones dentro de una misma función SI con Excel

Para poder poner dos condiciones dentro de Excel deberemos usar la función Y en Excel.

Para ello vamos a usar el siguiente esquema:

funcion si junto con la funcion y en excel

Como puedes ver en la imagen anterior hemos unido las dos variables en una única fila y la función que usaremos es la siguiente:

=SI ( Y ( A1 = "Rubia"; A2 = "Guapa" ) ; "OK" ; "NO OK")

En este caso habrá únicamente dos resultados. Si se cumplen las dos condiciones o si no se cumplen las dos condiciones.

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza… Quique es el fundador de esta web y frecuentemente se dedica a escribir… o cuando saca un hueco más bien.

(Visited 46.542 times, 1 visits today)
Categorías Funciones

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información ACEPTAR

Aviso de cookies
Shares
Share This