Función Y en Excel

Hay dos funciones básicas en Excel cuyo potencial no está totalmente reconocido… es como las pequeñas palabras, sin ellas no somos nadie pero con ellas tiene sentido la frase. Lo mismo pasa con la función Y en Excel y la función O. Estas dos sencillas funciones son de gran importancia y merece la pena conocerlas a fondo.

Sintaxis

Y(valor_lógico1; [valor_lógico2]; …)   O(valor_lógico1; [valor_lógico2]; …)

La función Y en Excel se encarga de evaluar 2 o más condiciones (valor_lógico1; [valor_lógico2]; …) introducidas por nosotros, devolviendo como resultado Verdadero si TODOS y cada uno de los argumentos se cumplen, es decir,  son verdaderos, o por el contrario devolviendo Falso si AL MENOS UNO de ellos es evaluado como falso.

Por otra parte, la función O también tiene la misión de evaluar dos o más condiciones (valor_lógico1; [valor_lógico2]; …). Sin embargo, en este caso el resultado de la función será Verdadero CON QUE HAYA UN ARGUMENTO que sea verdadero, mientras que para ser Falso, TODOS deberán ser falsos.

Ejemplos función Y en Excel

Con estos pequeños ejemplitos vamos a verlo aún más claro. En el primer caso la función Y devuelve un valor Verdadero porque las 3 condiciones impuestas lo son.

función excel y o

En cambio, si uno de los argumentos lo transformamos en falso, el resultado se vuelve Falso.

funcion_y_2

Ejemplos función O en Excel

Procedemos análogamente con la función O. En este primer ejemplo observamos que el resultado de la función es Verdadero ya que uno de los tres argumentos se cumple.

funcion_O_1

Sin embargo, si hacemos que todos ellos sean falsos, como es lógico, Excel nos devuelve también Falso.

funcion_O_2

Bonus Track: Ejercicio resuelto

En este bonus track os planteamos tres ejercicios de Excel para practicar el uso de la función Y y de la función O.

Supongamos que la celda A1=40 y la celda A2=”Rojo”.

Enunciado 1. Crear una fórmula mediante la función SI y la función Y que nos devuelva correcto si la celda A1 es menor que 50 y la celda A2 no está vacía.

Solución

=SI(Y(A1<50;A2<>””);”Correcto”;”Incorrecto”)

Enunciado 2. Crear una fórmula que evalúe los valores de A1 y A2 y si los dos están rellenos que devuelva OK y sino que devuelva “Error”.

Solución

=SI(Y(A1<>””;A2<>””);”OK”;”Error”)

Enunciado 3. Crear una fórmula que evalúe los valores de A1 y A2. Si al menos una de las celdas no está vacía que devuelva OK, en caso contrario que devuelva “KAO”.

Solución

=SI(O(A1<>””;A2<>””);”OK”;”KAO”)

Autor: Quique Arranz

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza... no dudes en contactar con él para cualquier duda que tengas.

2 opiniones en “Función Y en Excel”

  1. Es la primera vez que consulto esta pagina y es excepcional, por eso os pido vuestra ayuda para tratar de resolverme el problema que expongo a continuación. Quiero saber como crear una base de datos en una hoja con dos columnas, donde una sea de códigos y la otra sea de referencias y en otra hoja recuperar los datos de la primera hoja tan solo escribiendo el código, por ejemplo, creo la base de dados en la hoja uno y asigno diferentes congos a diferentes referencias y en la hoja dos introduzco cualquiera de los códigos de la hoja uno y me aparezca la referencia asignada a ese código, espero que no le resulte muy complicada mi exposición.

Comentarios cerrados.