Función SUMAR.SI en Excel o como hacer una suma condicional

función sumar.si en excel

La función SUMAR.SI en Excel nos permite sumar rangos que cumplen cierto criterio.

Existen dos maneras de usar esta función:

1. Si el propio rango a sumar es el que tiene que cumplir la condición.

Por ejemplo, si en la columna A tenemos valores negativos y positivos y queremos saber cuanto suman los positivos.

2. Si el rango que queremos sumar está condicionando por otro rango.

Por ejemplo, si en la columna A tenemos números de cuenta y en la B tenemos las entradas y las salidas y queremos sumar las entradas y salidas de una cuenta en concreto.

SINTAXIS

La sintaxis de la función SUMAR.SI en Excel es muy sencilla:

=SUMAR.SI(rango; criterio;[rango_suma])
  • Rango: es donde se encuentra nuestro rango de suma en el primer caso (columna A) o el rango donde está nuestra condición en el segundo caso (columna A).
  • Criterio: el criterio que queremos aplicar
  • [rango_suma]: en el segundo caso, será el rango donde están los valores que queremos sumar (columna B) una vez cumplida la condición impuesta por el criterio. Recuerda que se pone en corchetes [ ] los valores no obligatorios.

El tema de los rangos es relativamente sencillo. El asunto se complica en la sintaxis del criterio.

Ejemplos de criterios

Mayor que 0 = “>0”

=CONTAR.SI(A1:A10;">0")

Igual a 32 = 32

=CONTAR.SI(A1:A10;32)

Igual que la cuenta ABC003 = “ABC003”

=CONTAR.SI(A1:A10;"ABC003")

Igual que la celda C1 = C1

=CONTAR.SI(A1:A10;C1)

Mayor que la celda C1 = “>”&C1

=CONTAR.SI(A1:A10;">"&C1)

Ejercicio propuesto para aprender a usar SUMAR.SI en Excel

Supongamos que tenemos la siguiente lista de valores en la columna A y B (puedes copiarlos y pegarlos en una hoja de Excel):

A 10
A 2
AA 5
BB 9
AA 5
A 9
A 2
A 6
AA 5
BB 10

Queremos saber los siguientes valores:

  • Suma de los valores A
  • Suma de los valores AA
  • Suma de los valores >5
  • Suma de los valores <10

Para resolverlo hemos usado las siguientes fórmulas:

  • =SUMAR.SI(A1:A10;"A";B1:B10)
  • =SUMAR.SI(A1:A10;"AA";B1:B10)
  • =SUMAR.SI(B1:B10;">5")
  • =SUMAR.SI(B1:B10;"<10")

Bonus track: más ejemplos de suma condicional en Excel

Si quieres aprender más sobre cómo usar la función SUMAR.SI en Excel puede que te interese echarle un visazo a este artículo sobre tres maneras diferentes para hacer sumas condicionales en el que además aprenderás a usar la función SUMAR.SI.CONJUNTO.

Autor: Quique Arranz

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza... no dudes en contactar con él para cualquier duda que tengas.

14 opiniones en “Función SUMAR.SI en Excel o como hacer una suma condicional”

  1. Buen día Quique, tengo una plantilla en la que hay tres columnas, A es el día, B la meta (numero de ventas, en: 1,2,3,etc), y C que tiene las ventas reales.
    La cuestión es que debo sumar solo las celdas de C que superen las metas diarias en B, pero B varía todos los días.
    Podrías ayudarme? Desde ya muchas gracias!

  2. Quisiera saber cómo se hace lo siguiente. Tengo un rango de valores (desde a3:ar3), quisiera sumar tan solo los 15 mayores. Cómo debo hacerlo?

  3. Buenos dias, q buena pagina, una pregunta en excel quiero digamos que si le doy venta, la cantidad me reste en la columna que tengo la cantidad de inventario y si le doy compra me sume la cantidad. que funcion puedo realizar.

    1. Hola Jhon, con una función SI() lo puedes hacer perfectamente. Adicionalmente, yo crearía una lista desplegable con los valores VENTA y COMPRA para que no pudiera escribir otra cosa y que la tabla sea consistente. Saludos

  4. Hola!
    Necesito ayuda! necesito que de esta tabla, unicamente me sume los 2 valores mas altos de por cada categoria es decir que totalice los 2 puntajes mas altos del total de vueltas.
    Muchas Gracias

    Posición CATE Vuelta 1 Vuelta 2 Vuelta 5 Total
    1 BRA 4 3 1 #¡VALOR!
    2 HAW 3 4 2 #¡VALOR!
    3 HAW 2 3 3 #¡VALOR!
    4 HAW 8 2 5 #¡VALOR!

  5. Por favor necesito sabe si es posible con excel realizar lo siguiente:
    La letra A equivale a 10 puntos
    La letra B equivale a 5 puntos
    La letra C equivale a 7.5

    Entonces si yo registro en una celda la letra A y en otra B el promedio de de 7.5 que equivale a C

  6. hoa tengo una situacion quiero sumar cuantas veces aparece royalton y otra cuantas veces aprece chic en diferentes celdas con sumar si uso la formula=SUM(A9:A11,”royalton”) y me da cero que esta mal

  7. y que tal si tengo esto:

    a – 3 – F
    a – 2 – V
    b – 5 – F
    b – 6 – V
    b – 7 – V
    a – 2 – F
    c – 3 – F
    c – 3 – F

    Quiero que solo sume las “F” en los que dicen “a” y “2”

    Si me expliqué?

Comentarios cerrados.