Función ÍNDICE en Excel

función indice en excel

Se trata de una función tremendamente útil y no siempre muy conocida. La función INDICE en Excel es la encargada de devolver el valor de una celda dentro de una matriz o tabla dada la posición de la fila y/o la columna que ocupa dentro de ella.

Sintaxis

La función INDICE nos permite encontrar un valor en un rango (matriz) especificando el valor de la posición del dato buscado a través de la fila y la columna.

=INDICE(Rango;núm_fila;núm_columna)
  • Rango: es el rango de celdas de toda nuestra matriz o tabla.
  • Núm_fila: es el número de fila en la que está situada la celda que buscamos dentro de la tabla.
  • Núm_columna: es el número de columna en la que está situada la celda que buscamos dentro de la tabla. Este valor es opcional

Ejemplo de la función INDICE en Excel

Supongamos que nos es dada la siguiente tabla en una hoja de cálculo de EXCEL:

función indice en excel

Si deseamos obtener el elemento correspondiente a la segunda fila y tercera columna, no hay más que escribir la siguiente función en cualquier celda

=INDICE(B4:D7;2;3)

En la siguiente imagen puede verse la función escrita en la celda C5 haciendo referencia al rango de datos que está recuadrado en la imagen.

función indice en excel

Como puede apreciarse, el elemento buscado es el 5 tal y como se esperaba.

Bonus Track: ejercicio.

En la columna A a partir de la celda 4 se han escrito los números del 1 al 10. Queremos saber el valor que ocupa la celda 7 contando desde la celda A1 en la columna.

La solución es utilizar la función INDICE en Excel sabiendo que el rango que tenemos que poner es la columna A y la celda de la que queremos conocer la posición se encuentra en la fila 7. Por lo tango, la función será la siguiente:

=INDICE(A:A;7)

No hemos usado el valor del argumento columna pues en este caso, al ser una matriz de infinitas filas y una sóla columna no nos hace falta la referencia de la columna.

Autor: Quique Arranz

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza... no dudes en contactar con él para cualquier duda que tengas.

6 opiniones en “Función ÍNDICE en Excel”

  1. Buenas Noches me podrian ayudar en lo siguiente, yo quisiera ejemplo si en b1 yo coloco Carlos en C1 me aparezca CA este seria como un codigo para Carlos pero asi me pase con varios datos que suministre en un determinado campo de celdas, que no sea precisamente en la b1 y c1, que si yo coloco Pedro en B5 asi como en B10 en C5 y en C10 el codigo de PEdro sea PE……..

    como puedo obtener esto que no se….

    Agradecido por su valiosa ayuda

    1. Hola Walter, no estoy seguro de lo que preguntas. A primera vista, lo que dices se puede construir con dos fórmulas que vas arrastrando en el rango o que puedas poner en una tabla de excel. La fórmula sería MAYUSC(IZQUIERDA(C5;2)). Atención porque si lo que quieres es usar los código en la columna C para otras cosas, te deberías asegurar de que el modelo es consistente. Por ejemplo, podrías tener Pedro Guerrero y Pedro García y, en ambos casos, el resultado de la fórmula en C sería PE. Saludos,

  2. Hola buena página. Me gustaría saber como se introduce esta fórmula en excel:
    INDICE(Tablas!N24:Q30;Funcionamiento!M20;Funcionamiento!M19)
    Es que me estoy volviendo loco ejje

    1. Hola Marco, no se muy bien a qué te refieres. Supongo que es al funcionamiento pero por si acaso… las fórmulas en Excel han de ir precedidas del símbolo = o del símbolo +. Un saludo!

Comentarios cerrados.