Función ÍNDICE en Excel

Se trata de una función tremendamente útil y no siempre muy conocida. La función INDICE en Excel es la encargada de devolver el valor de una celda dentro de una matriz o tabla dada la posición de la fila y/o la columna que ocupa dentro de ella.

Sintaxis

La función INDICE nos permite encontrar un valor en un rango (matriz) especificando el valor de la posición del dato buscado a través de la fila y la columna.

=INDICE(Rango;núm_fila;núm_columna)
  • Rango: es el rango de celdas de toda nuestra matriz o tabla.
  • Núm_fila: es el número de fila en la que está situada la celda que buscamos dentro de la tabla.
  • Núm_columna: es el número de columna en la que está situada la celda que buscamos dentro de la tabla. Este valor es opcional

Ejemplo de la función INDICE en Excel

Supongamos que nos es dada la siguiente tabla en una hoja de cálculo de EXCEL:

función indice en excel

Si deseamos obtener el elemento correspondiente a la segunda fila y tercera columna, no hay más que escribir la siguiente función en cualquier celda

=INDICE(B4:D7;2;3)

En la siguiente imagen puede verse la función escrita en la celda C5 haciendo referencia al rango de datos que está recuadrado en la imagen.

función indice en excel

Como puede apreciarse, el elemento buscado es el 5 tal y como se esperaba.

Bonus Track: ejercicio.

En la columna A a partir de la celda 4 se han escrito los números del 1 al 10. Queremos saber el valor que ocupa la celda 7 contando desde la celda A1 en la columna.

La solución es utilizar la función INDICE en Excel sabiendo que el rango que tenemos que poner es la columna A y la celda de la que queremos conocer la posición se encuentra en la fila 7. Por lo tango, la función será la siguiente:

=INDICE(A:A;7)

No hemos usado el valor del argumento columna pues en este caso, al ser una matriz de infinitas filas y una sóla columna no nos hace falta la referencia de la columna.

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza… no dudes en contactar con él para cualquier duda que tengas.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información ACEPTAR

Aviso de cookies
Shares
Share This

Comparte este post

Comparte si te resulta útil la información.