Función FILA y Función COLUMNA

Las funciones FILA y COLUMNA en Excel nos permite conocer la fila o columna de una referencia. Si bien estas funciones a menudo son muy poco empleadas por los usuarios, en ocasiones pueden resultar de gran utilidad.

Sintaxis

FILA (referencia), COLUMNA (referencia)

La función Fila devuelve el valor que corresponde al número de fila que hemos indicado en el argumento. Es decir, para la función: FILA(B43), el resultado que obtendremos será precisamente 43.

La función Columna por su parte, devuelve el valor que corresponde al número de columna que hemos indicado en el argumento. Es decir, para la función: COLUMNA(B43), el resultado será 2, puesto que la columna “B” es la que situada en segundo lugar en una hoja de cálculo.

En caso de dejar la referencia en blanco, es decir, FILA() o COLUMNA(), el programa por defecto devolverá la fila o la columna de la celda en la que hayamos escrito dicha función.

Ejemplo

Si nos encontramos una hoja Excel con el siguiente contenido:

Fórmula, Fila, Row, Tips, Excel funciones fila y columna en excel

y nos interesa multiplicar al primer término de la lista por 2, al segundo por 3, al tercero por 4 y así sucesivamente, no habría más que escribir la siguiente función en la casilla C3 y arrastrar hasta C8. Hazlo y comprobarás que se cumple lo aquí señalado.

funciones fila y columna en excel

Ejemplo 2

Cuando queremos formar una tabla a través de los elementos de una fila, estas funciones pueden ser de gran utilidad combinándolas con la función INDICE.

Dado el siguiente caso:

funcion_ROW(3)

Si deseamos crear una tabla de dos filas donde queden recogidos los productos vendidos de cada año, una posibilidad para llevarlo a cabo sería mediante la siguiente fórmula:

=INDICE($B$3:$B$28;13*(FILA(A1)-1)+COLUMNA(B1);1)

Si la escribimos por ejemplo sobre E5 y arrastramos convenientemente llegamos al resultado buscado:

funcion_ROW(4)

La explicación de la fórmula es la siguiente:

  • =INDICE($B$3:$B$28; es el rango de la tabla, sobre el que queremos buscar los datos.
  • =INDICE($B$3:$B$28;13*(FILA(A1)-1)+COLUMNA(B1) corresponde al número de fila. Respecto a la primera parte “13*(FILA(A1)-1)”, sabemos que cada año tiene la primera celda en blanco y luego doce más, una por cada mes, es decir, trece en total. Por ello, como nuestra tabla resultado tiene dos filas, al arrastrar la fórmula, en la fila de arriba siempre tendremos 13*(1-1), o sea 0, mientras que en la de abajo, al haber arrastrado la fila, ésta se habrá incrementado en una unidad, luego será (13*(2-1)), por tanto, 13. Con ello conseguimos situar siempre al programa en la primera celda del año de estudio, sea éste 2012 o 2013. La segunda parte “+COLUMNA(B1)” tiene como misión buscar el mes en cuestión dentro de ese año en que nos acaba de situar el inicio de la fórmula. Su valor es 2 inicialmente, ya que la primera celda del año está en blanco. Después simplemente va sumando uno a medida que vamos arrastrando hacia la derecha la fórmula, para ir pasando a febrero, marzo…
  • =INDICE($B$3:$B$28;13*(FILA(A1)-1)+COLUMNA(B1);1) corresponde al número de columna. En este caso al haber sólo una pues no hay duda de que es “1” el valor a seleccionar.
Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza… no dudes en contactar con él para cualquier duda que tengas.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información ACEPTAR

Shares
Share This

Comparte este post

Comparte si te resulta útil la información.