La función CONTAR.SI con todo detalle

Como ya hemos comentado muchas veces previamente Excel es mucho más que una calculadora. La función CONTAR en Excel y la función CONTAR SI en Excel junto con la función CONTAR SI CONJUNTO son funciones increíblemente potentes y versátiles y su utilidad está fuera de dudas.

A continuación os mostramos un montón de ejemplos para que puedas ver todas las maneras que tienes en Excel para contar. Puedes contar palabras, números, conjuntos de celdas o casi cualquier cosa que se te ocurra. Para ello siéntate cómodo que empezamos.

La función CONTAR, antecesora de CONTAR SI

Antes de hablar de la función CONTAR SI que te sirve para contar los valores de una lista dado unos criterios te hablaré de la importantísima función CONTAR. La verdad es que la sintaxis de esta función de Excel es muy sencilla y nos permite conocer el número de celdas de un rango seleccionado que tengan valores numéricos. La sintaxis de esta función es:

=CONTAR(rango1;rango2;rango3...)

Es decir, podemos tener varios rangos de celdas con los que poder contar los valores numéricos.

Ejemplo 1: contar valores numéricos en un rango

En el siguiente ejemplo vamos a ver como contar valores numéricos en un rango de celdas continuo. Para ello usaremos la siguiente sintaxis:

=CONTAR(A1:A10)

El resultado de aplicar esta función será:

función contar si excel ejemplo

El resultado de la operación anterior será 3 puesto que sólo contaremos los 3 valores numéricos del rango.¡

Ejemplo 2: contar valores numéricos en varios rangos

En este ejemplo vemos en la siguiente imagen como los argumentos de la función CONTAR son dos. No hace falta que usemos varias funciones CONTAR sino una único función.

función contar excel

 

La función CONTARA

La función CONTARA es la evolución de la función CONTAR. Esta función nos permite contar los valores numéricos y no numéricos de un rango. Es decir, cuanta las celdas no vacías de un rango de celdas.

La sintaxis es igual que en el caso de la fórmula CONTAR:

=CONTARA(rango1;rango2;...)

Por ejemplo, en la siguiente imagen vemos un rango de celdas con valores tipo:

  • Numéricos
  • De texto
  • Errores
  • Verdader/Falso

Y la función los cuenta todos.

función contar a excel

El resultado de la función del ejemplo será 7 puesto que tiene en cuenta todos lo valore no vacíos de las celdas.

La función CONTAR SI en Excel

Esta fórmula de Excel es de las más importantes que debemos aprender pues nos permite contar elementos dada una condición. Por ejemplo, si tenemos un listado de valores y queremos contar aquellos que sean mayores que 10 usaremos la fórmula CONTAR SI.

La sintaxis de la función CONTAR SI es muy sencilla.

=CONTAR.SI(rango;criterio)

Donde:

  • Rango es el rango de celdas que queremos contar de manera condicional.
  • Criterio es el que aplicamos para contar aquellas celdas que cumplan determinado criterio

Por ejemplo, algunos criterios que se pueden usar son:

  • Igual a
  • Menor que
  • Mayor que
  • Menor o igual que
  • Mayor o igual que
  • Contiene

Estos criterios son bastante evidentes y su significado no hace falta explicarlo. Ahora bien, la manera de introducirlos en una fórmula puede ser algo más confuso.

Función CONTAR SI con criterio “igual a”

Si quieres usar el criterio “igual a” con valores numéricos la sintaxis que debemos usar es:

=CONTAR.SI(A1:A10;15)

En cambio, si queremos usarlo con valores de tipo texto como en el siguiente ejemplo usaremos:

=CONTAR.SI(A1:10;"aa")

Es decir, tenemos que poner el argumento entre comillas.

función contar si excel igual a

También podremos usar un criterio del tipo “igual a” en Excel que nos permita hacer referencia a una celda.

Por ejemplo, podemos usar la fórmula:

=CONTAR.SI(A1:10;B1)

De esta manera, contaremos todas las celdas cuyo contenido sea igual al valor de la celda A1 ya sea un número o un texto.

Función CONTAR SI con criterio “mayor que” / “menor que”

Con la función CONTAR SI podemos usar un criterio comparativo de valores que nos permita conocer el número de celdas de un rango cuyo valor sea menor o mayor que el valor del criterio.

Para poder hacerlo usaremos la siguiente sintaxis:

=CONTAR.SI(mi_rango;"<mi_valor_criterio")

Fíjate que al usar el operador < (o >) usamos también las comillas dobles. Esto es así porque estamos combinando un caracter de tipo texto con un número y no podemos hacerlo sin comillas (“”).

Por ejemplo, si queremos contar todos los valores menores de 10 del rango A1:A10 usaremos la siguiente expresión:

=CONTAR.SI(A1:A10;"<10")

En la siguiente imagen se verá más claro:

función contar si excel contar valores menores que

El resultado de este ejemplo es 5 porque sólo hay cinco valores que sean menores de 10.

Pero puede pasar que no conozcamos el valor del criterio y que esté esté en una celdas así que usaremos la fórmula:

=CONTAR.SI(A1:A10;"<"&B1)

Donde en la celda B1 es la que nos marcará el criterio para contar las celdas.

Erro de la función CONTAR SI en Excel

Si intentamos usar la misma fórmula pero sin comillas Excel nos mostrará el siguiente error:

función contar si error

Aunque no es muy indicativo nos permite conocer que hay un problema en nuestra fórmula CONTAR SI.

Función CONTAR SI con criterio “mayor o igual que” / “menor o igual que”

Es muy similar al apartado anterior, la diferencia es que antes del símbolo “mayor que” (o “menor que”) pondremos el símbolo de igual (=).

En el mismo ejemplo que antes, si queremos contar los valores que son mayores o iguales a 10 usaremos la siguiente fórmula de Excel:

=CONTAR.SI(A1:A10;"<=10")

Nota: es muy importante que pongas los símbolos de menor que (<) o mayor que (>) antes del símbolo igual (=). Sino Excel nos devolverá 0.

Función CONTAR SI con criterio “contiene”

Este es un pequeño truco que nos permite contar todas las celdas que contengan un determinado conjunto de caracteres. Por ejemplo, en el siguiente caso queremos contar todas las palabras que tengan, al menos, una “a”.

función contar si que contenga

Este ejemplo nos sirve con mayúsculas y minísculas independientemente. Como puedes ver, hay cinco celdas que contienen una “a” ya sea esta mayúscula o minúscula.

También podemos ser más restrictivos y buscar todas las celdas que con contienen una “A” pero con un determinado número de caracteres. Por ejemplo si usamos el criterio:

  • “?a” buscaremos todas las celdas que contienen dos caracteres y terminan en “a”
  • “a?” es el caso opuesto al anterior. Se cuentan todas las celdas que tengan dos caracteres y contengan una “a”

Básicamente este truco funciona con tantas interrogaciones como queramos para contar caracteres antes o después.

Las siguientes imágenes te ayudarán a entender mejor este concepto.

Ejemplo CONTAR SI 1

En este ejemplo contamos todos los valores que tengan 4 caracteres y terminen en la letra a. Para ello usamos la fórmula:

=CONTAR.SI(D1:D10; "???a")

En la siguiente imagen, las celdas señaladas en amarillo son aquellas que cumplen con el criterio y, por tanto, las que se cuentan.

ejemplo función contar si

Ejemplo CONTAR SI 2

En este caso usamos la fórmula CONTAR SI para contar aquellas celdas que tienen un numero determinado de caracteres que tienen unas características concretas. En el ejemplo estamos buscando todas las celdas que tengan una b en la segunda posición y una a al final de la palabra.

La fórmula que hemos usado es:

=CONTAR.SI(D1:D10;"?b?a")

ejemplo función contar si con texto

Función CONTAR SI con criterio “diferente de vacío”

Si queremos contar celdas no vacías deberemos usar el operador “<>” que en programación implica “diferente de”. El problema que tenemos es que debemos unir este operador lógico con el símbolo de vacío que en Excel es con dobles comillas (“”). Para poder unirlos deberemos usar el símbolo de unión &.

La fórmula que deberemos utilizar es:

=CONTAR.SI(D1:D10;"<>"&"")

En la siguiente imagen se cuentan aquellas celdas marcadas en amarillo:

función contar si excel valores no vacíos

La función CONTAR SI CONJUNTO  en Excel

Esta función de Excel funciona prácticamente igual que su predecesora, la función CONTAR SI. Mediante esta función podemos contar celdas con varios criterios. La sinxtaxis de esta función es:

=CONTAR.SI.CONJUNTO(rango1;criterio1;…….;rango n; criterio n)

Es decir, podemos usar varios rangos y criterios siempre y cuando sigamos las normas que hemos explicado previamente para los criterios. Además, si usamos varios rangos deberán tener todos la misma longitud, es decir el mismo número de filas o columnas.

En el siguiente ejemplo estamos contando todos los valores mayores de 10 y que en la celda de la derecha tengan un valor menor igual a la letra A. Para ello usamos la siguiente sintaxis:

=CONTAR.SI.CONJUNTO(rango1;">10";rango2;"A")

Donde estamos obligando a contar las celdas que cumplen que en el rango 1 los valores son mayores que 10 y en el rango 2 las celdas tengan el valor de “A”.

ejemplo función excel contar si conjunto

Ejercicio con la función CONTAR SI en Excel

Dada la siguiente tabla:

ejercicios resueltos función contar si excel

Se pide:

  1. Contar todos las celdas que sean iguales a “AA”.
  2. Contar todas las celdas cuyo valor termine en la letra “A”
  3. Contar todas las celdas cuyo valor comience por “AA”.
  4. Contar todas las celdas mayores que 10.
  5. Contar todas las celdas menores que la celda H3 (valor igual a 8)
  6. Contar todas las celdas cuya cadena de texto comience por la letra A y tenga en la tercera posición una B
  7. Que no estén vacías.

Para poder llevar a cabo este ejercicio puedes usar el enunciado que encontrarás en el siguiente enlace: Ejercicios Resueltos función CONTAR SI Enunciado Ejercicios función CONTAR SI

Soluciones a los ejercicios de la función CONTAR SI

Si quieres descargar estos ejercicios puedes hacerlo dándole a Like en Facebook a través de los siguientes botones y después podrás ver el link de descarga.

 

Quique es un fanático del Excel desde que empezó a trabajar con ello hace unos pocos años. Adquirió su conocimiento a través de Google y de infinitas pruebas y más pruebas. Además, Quique es un entusiasta de su familia (mujer e hijos), del deporte y de la cerveza… no dudes en contactar con él para cualquier duda que tengas.

Uso de cookies

Este sitio web utiliza cookies para que usted tenga la mejor experiencia de usuario. Si continúa navegando está dando su consentimiento para la aceptación de las mencionadas cookies y la aceptación de nuestra política de cookies, pinche el enlace para mayor información ACEPTAR

Aviso de cookies
Shares
Share This

Comparte este post

Comparte si te resulta útil la información.